Newsletter: Learn More ||| Multimedia Presentation Software |||
How to combine video & audio with PowerPoint and other Presenter projects
NOTE: If you have WildPresenter Pro 3.3 or higher, the software now includes a wizard that enables you to combine PowerPoint and video with 3 easy steps - select a PowerPoint, select a video and click "next". View this online demo for more information
This tutorial applies to WildPresenter Pro 2+.
Contents
Getting Started
The first step is to encode your video. You do this to determine the duration of the video and the video framerate which will also be used for the imported PowerPointfile.

The duration of the video is shown in the Vid/Aud tab of the media importer once you import the video. You can use this information to help you sync up the video with the PowerPoint.

To keep things simple, you probably want the framerate of your project and your video to be the same (though this is not mandatory and there are ways to handle different framerates that will be discussed more below). So if you create a video with a SWF framerate of 15, for instance, you will probably want the PowerPoint SWF to have a SWF framerate of 15. For this project we will set the framerate to 15 so the PowerPoint SWF and the video SWF will both run at 15 frames per second.
Top
Encoding video
Open Presenter, select Create New Project and name your project.
To import and convert the video select the Audio/Image/Video Importer button.
In the File tab Browse to your video file and select a Preset.

Here you need to decide whether to use SWF or FLV video. For this tutorial we will use SWF video, because it is easier to sync up. SWF video appears in full on the Presenter timeline and can be clicked through frame by frame - unlike FLV files - which makes it easier to exactly synchronize them the way you wish. However, there are 2 circumstances where you will want to use FLV:

  • if your video is longer than 16,000 frames (about 8 min 50 seconds at 30 fps and 17 min. 40 seconds at 15 fps). This is because the SWF format has a 16,000 frame limit.
  • if your PowerPoint project or other SWF has already been created at a different framerate than the framerate you want to use for your video. FLV video runs independently of your project and so you can set any framerate you wish for FLV video. Remember that if you use FLV video, your video will be in the “Load External Files” folder in your Presenter project directory and you must include that folder with your project.

(If you already have your video encoded into SWF and it has a different framerate than the framerate you wish to use for your PowerPoint file, you can set the video SWF to use “Load External File” play mode. Remember that if you use “Load External File” play mode, your video will be in the “Load External Files” folder and you must include that folder with your project.)

In the Vid/Aud tab you can adjust the video dimensions and the framerate. For this tutorial the video dimensions will be 320x180. I will set the video and SWF framerates to be 15 which is approximately half the 29.9 framerate (or close enough to half) of the source video. Remember that it’s always good for your video framerate to be a factor of the source video framerate.

You can also apply image filters, de-interlacing, editing, cropping and other features that are in the media encoder to your encoded video. For more information on these features, check the Presenter help file.

To encode the video click the Encode button.

Set the project framerate and dimensions to be equal to the framerate and dimensions of your encoded video. You can do this in the Project settings window.

To set the frame rate open the Project Settings window and select the Output tab.

Now save your project (File>Save) and export your video (File>Export). You will import the video later into your final project.

For more information on how to encode video see this tutorial.

Top
Syncing video and PowerPoint
There are a few ways to sync up PowerPoint and video so that you can have the video hit specific points in the PowerPoint. Here is a brief overview of three ways to do this. A detailed description of each method follows below.

Method 1: Video on single slides

This is the most basic method in which you can add individual videos (or audio) to any number of individual slides. To do this you

  • open Presenter and create a new project
  • set your project framerate
  • import the PowerPoint file into Presenter
  • import the video (or audio) to the specific slide that you wish the video to appear on.

This method is ideal for adding a single video to a single PowerPoint slide, or synchronizing multiple videos with multiple slides.

Presenter currently plays individual slides sequentially and you cannot have files that extend over multiple slides (other than audio that uses the “Project audio” option in the Flash SWF tab of the Project settings window). So to add video over multiple slides requires a couple of additional techniques which are described in the next 2 methods.

Method 2: Video over multiple slides with a timed project

In this method you have a video (or audio) run over several slides of a timed PowerPoint file, or the entire project. To do this you

  • open Presenter and create a new project
  • set your project framerate
  • import the PowerPoint file into Presenter
  • set the timing of the slides using the timed slide navigation so that it syncs with the video, and then make any other changes you wish to the presentation
  • export the PowerPoint as a SWF
  • reimport the converted SWF into a new Presenter project
  • import the video into Presenter and sync the video with the PowerPoint SWF

Method 3: Video over multiple slides with a slide based project

In this method you have a video (or audio) run over several slides of a PowerPoint file, or the entire project by converting the PowerPoint into individual SWFs. To do this you

  • open Presenter and create a new project
  • set your project framerate
  • import the PowerPoint file into Presenter
  • make any changes you wish to the presentation
  • export each slide of the PowerPoint as a separate SWF (please note that PowerPoint slide transitions will be lost using this method, but can be added back later using Presenter animations).
  • reimport the converted SWFs into a new Presenter project and lay them out on the timeline in a single slide
  • import the video into Presenter and sync the video with the PowerPoint SWFs
Top
Method 1: Video on single slides - in detail
Open Presenter, select Create New Project and name your project.
Set your framerate. Your converted PowerPoint SWF (including all the animations and transitions) will be set to use the project framerate you have set when you import the file (View>Project Settings).
Import your PowerPoint file by selecting File>Import File.

Now import the video or audio file you wish to add (or if you have previously encoded the video, import the SWF video file that you encoded earlier) by selecting File>Import File.

This method is ideal for synchronizing multiple videos with multiple slides. You can now add video to other slides.

You can now adjust the format of your slides and make any other changes that you wish.

When complete export your project.

Export your file by selecting File>Export File.

Top
Method 2: Video over multiple slides with a timed project - in detail

In this method, we will time the PowerPoint slide navigation based on the video length. An example scenario would be having a one-minute video with a six-slide PowerPoint presentation. You could time the PowerPoint slide transitions every ten seconds so the presentation will end when the video is complete.

Preparing the PowerPoint file

Open Presenter, select Create New Project and name your project.

Set your framerate. Your converted PowerPoint SWF (including all the animations and transitions) will be set to use the project framerate you have set when you import the file (View>Project Settings).
Import your PowerPoint file by selecting File>Import File.
At the dialog box select the ‘Fully editable PowerPoint’ button. Also check the “Resize project to PowerPoint dimensions” checkbox.
Choose an insertion point at the dialog box.

As an example, this project is to sync up the PowerPoint with video. The video file used for this tutorial is 2:38 minutes (158 seconds) long; the PowerPoint file has 8 slides. The timing for each slide can roughly be set to 20 seconds to play the PowerPoint file for the duration of the video. If you want some slides to transition faster or slower you can adjust individual transition lengths as long as the totals sync the way you want them to.

To adjust the slide navigation for a specific slide, select that slide and then open the Slide Settings window (View>Slide settings), select the Timed button and enter in the appropriate time. Repeat this step for each slide.

(Another option is to set the navigation once on the master slide. This is the easiest way to do it. To do this, select the “Slide Master” and then set the timed navigation. Please note that using this method, each slide must have the same duration.)

Now that you have reviewed the slides and set the slide timing you can export the PowerPoint SWF file. You export the file so that you can turn the multislide project into a single SWF file. Then you can reimport this SWF file later and change the dimensions.

To export select File>Export File

We will now start a new project to complete the tutorial.

To start a new project select File>New Project.

Name your new project

Open the Project Settings window and enter in the final project dimensions. The dimensions for this project are 700 x 290 (these dimensions were created by reducing the PowerPoint file width by 50%, which is how it will be displayed in the new project, then adding the width of the video and then adding some additional space for a border around the video). You may choose the dimensions that suit your project best. Adjust the project Frame Rate to 15 to match the video as previously discussed.

Importing the converted PowerPoint SWF file

You can now insert the PowerPoint SWF file into the final project. You can simply drag and drop the file into the stage or you can use File>Import File.

Resizing the PowerPoint file

Now that the project dimensions have been set you can resize the PowerPoint SWF that you just imported.

To resize the SWF file open the Object Settings window. In the Appearance tab adjust the dimensions. To have the dimensions scale perfectly you can select the “Constrain Proportions” option so when you change either the height or width, the other setting will change automatically to maintain the same aspect ratio.

For this project we will reduce the size of the imported PowerPoint by 50%.

Now you can import the converted video SWF. Once the video is placed on the stage you can adjust its placement using the variety of adjustment tools included with Presenter.

This is the Align toolbar (View>Toolbars>Align Toolbar).

You can also adjust when the video file begins by moving the file on the timeline.

You can make timeline adjustments in the Object Settings window or by simply dragging the object on the timeline to the desired position.

Once you are finished making your adjustments you can export your Project.

To export your project select File>Export File
There is additional information below on how to add a player and/or a preloader to your final project.
Top
Method 3: Video over multiple slides with a slide based project - in detail

Open Presenter, select Create New Project and name your project.

Set your framerate. Your converted PowerPoint SWF (including all the animations and transitions) will be set to use the project framerate you have set when you import the file (View>Project Settings).

Import your PowerPoint file by selecting File>Import File.
At the dialog box select the ‘Fully editable PowerPoint’ button. Also check the “Resize project to PowerPoint dimensions” checkbox.
Choose an insertion point at the dialog box.

Now that the PowerPoint is inserted you can make any changes you wish to the presentation.

Now your slides are ready to be exported. Each slide will be exported individually. Later each SWF file will be inserted back into the project and placed, in order, on the timeline. PowerPoint slide transitions will be lost using this method, but can be added back later using Presenter animations.

Select the slide you want to export and click the Export File button.
A dialog box will open. Name the file and click Save

Now a dialog box will open asking if you want to export all the slides.

Click No to export only the individual slide.

Repeat until you have all necessary slides exported.

Open a new Presenter project by selecting File>New Project.

Open the Project Settings window and enter in the final project dimensions. The dimensions for this project are 700 x 290 (these dimensions were created by reducing the PowerPoint file width by 50%, which is how it will be displayed in the new project, then adding the width of the video and then adding some additional space for a border around the video). You may choose the dimensions that suit your project best. Adjust the project Frame Rate to 15 to match the video as previously discussed.

We will now import in all the SWF files we just created and place them on the timeline.

Import your SWF files by dragging the files onto the stage.

Click no at the dialog box. We want all the files to be on one slide.
Place the files on the timeline in the order they will play.

Once all the slides have been imported, you can resize them to fit your new project.

To resize the SWF file open the Object Settings window. In the Appearance tab adjust the dimensions. To have the dimensions scale perfectly you can select the “Constrain Proportions” option so when you change either the height or width, the other setting will change automatically to maintain the same aspect ratio.

For this project we will reduce the size of the imported PowerPoint by 50%.

Now import the SWF video file that you encoded earlier by selecting File>Import File.

Sync the PowerPoint files with the video file on the timeline to complete your project.

You can set the duration for each slide by changing the “Keep Last Frame for” option in the Object settings>Play tab, or by clicking on the right edge of the slide as it appears on the timeline and extending it by dragging it to the desired length. You can set the desired duration by multiplying desired seconds by framerate.

Adding Animations

As previously mentioned, since we exported each slide individually we lost any of the slide transitions that were originally in the PowerPoint file. We can now add the transitions back using the animations included with Presenter.

To add animations select a file on the timeline. Open the Object Settings window and select the Animations tab. Choose an animation from the drop down list. Repeat if necessary.

When you are finished making adjustments export your project.

Export your file by selecting File>Export File
Top
Information on adding play controls to your project

If you wish to add play controls there are several options:

  1. Add a separate player to both the converted PowerPoint SWF and the video.  To do this, right-click on the SWF on the timeline and select “Add player/preloader”.

This method has the benefit that it can be used with either “Stream” or “Load External File” play modes, so if you had to set either the imported PowerPoint SWF or the video to use Load External File play mode, you may want to use this mode.

2. Add a player to just the PowerPoint SWF or just the video. This is the same as above, but you just add the player to one of the 2 objects.

3. Add a single player to the entire project that controls both the PowerPoint SWF and the video. This is the method that we will use for this project.

To use this option, use the Player tab in the Project setting window to export your project with a player. The play controls will affect both the PowerPoint SWF and the video SWF. The benefit of the third method is that it keeps the entire project in sync at all times whereas the previous 2 methods will allow the viewer to take the project out of sync by using the play controls on one object and not the other.

To add a player to the project open the Project Settings window (View>Project Settings) and select the Players tab. Check the Include player when exporting box and select a player.

Top
Information on adding slide player navigation to your PowerPoint file

WildPresenter can export any project - including your converted PowerPoint file - with a slide navigation player that displays your slides in thumbnail form so viewers can view and navigate your output via a series of slide thumbnails and/or slide descriptions.

This is described completely in this tutorial.

You can use this method to add this type of navigation to your PowerPoint SWF. If you use this option, you will need to import the slide navigation player output SWF into your project instead of the standard output and you will also need all the files described in the above referenced tutorial.

Top
Information on adding a preloader to your project

If you wish to add a preloader there are several options:

  1. Add a preloader to both the converted PowerPoint SWF and the video. To do this, right-click on the SWF on the timeline and select “Add player/preloader”.

    This method has the benefit that it can be used with either “Stream” or “Load External File” play modes, so if you had to set either the imported PowerPoint SWF or the video to use Load External File play mode, you may want to use this mode.

2. Add a preloder to just the PowerPoint SWF or just the video. This is the same as above, but you just add the player to one of the 2 objects.

3. Add a preloader to the entire project that controls both the PowerPoint SWF and the video:

To use this option, use the Flash SWF tab in the Project setting window to export your project with a preloader. The play controls will affect both the PowerPoint SWF and the video SWF. The benefit of the third method is that it keeps the entire project in sync at all times whereas the previous 2 methods will allow the viewer to take the project out of sync by using the play controls on one object and not the other.

To add a preloader open the Project Settings window, select the Flash SWF tab and check the Preload box.

Top
Additional Information

With the PowerPoint file and video in place you can add additional bits of information to the project. For this tutorial in the space remaining under the video I am going to insert additional information (website, email, phone number).

To create text effects you can use the text animation tool. To learn more about animated text read this tutorial.
Top
Conclusion

Once completed your project should look similar to the one posted on our examples page here.

If you would like, you may download the source files used in this tutorial.

This tutorial is meant to provide you with the basics of combining video with PowerPoint. Presenter provides a rich array of features and options, and you will no doubt wish to explore these in greater depth. All of Presenter’s features are explained in the help file.

Top
 
©2013 Wildform, Inc | Policies | Contact Us | Newsletter Options